'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Stimulsoft Reports.Net discussion
Post Reply
mrapi
Posts: 252
Joined: Sat Dec 20, 2008 1:08 am

'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by mrapi » Mon Apr 05, 2021 1:08 pm

Hi
I'm trying to display Blazor WebAssembly report in modal just as a report is shown in winforms dialog
for that I use AntDesign modal component and 'Change viewer options' from your git examples
-I've added Antdesign package
- register the service in Program.cs: builder.Services.AddAntDesign();
- added @using AntDesign in _Imports.razor
-added <AntContainer /> in App.razor
-added in wwwroot/index.html <link href="_content/AntDesign/css/ant-design-blazor.css" rel="stylesheet" /> and <script src="_content/AntDesign/js/ant-design-blazor.js"></script>
(steps got from https://antblazor.com/en-US/docs/introduce )

I've attached a sample project,a regular component is shown fine but when I try to show StiBlazorViewer component in Ant modal,the report is show but menus no working and in console got:
'StiJsViewer' was undefined

Code: Select all

blazor.webassembly.js:1 crit: Microsoft.AspNetCore.Components.WebAssembly.Rendering.WebAssemblyRenderer[100]
      Unhandled exception rendering component: Could not find 'StiJsViewer.UpdateViewerWebAssembly' ('StiJsViewer' was undefined).
      Error: Could not find 'StiJsViewer.UpdateViewerWebAssembly' ('StiJsViewer' was undefined).
          at http://localhost:50502/_framework/blazor.webassembly.js:1:1287
          at Array.forEach (<anonymous>)
      ....
Microsoft.JSInterop.JSException: Could not find 'StiJsViewer.UpdateViewerWebAssembly' ('StiJsViewer' was undefined).
Error: Could not find 'StiJsViewer.UpdateViewerWebAssembly' ('StiJsViewer' was undefined).
    at http://localhost:50502/_framework/blazor.webassembly.js:1:1287
    at Array.forEach (<anonymous>)
    at e.findFunction (http://localhost:50502/_framework/blazor.webassembly.js:1:1247)
....

thanks
Attachments
Change viewer options.zip
(368.37 KiB) Downloaded 1 time
Last edited by mrapi on Tue Apr 13, 2021 5:45 am, edited 2 times in total.
Lech Kulikowski
Posts: 3463
Joined: Tue Mar 20, 2018 5:34 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by Lech Kulikowski » Tue Apr 06, 2021 11:18 pm

Hello,

We need some additional time to investigate the issue, we will let you know about the result.

Thank you.
#3861
Lech Kulikowski
Posts: 3463
Joined: Tue Mar 20, 2018 5:34 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by Lech Kulikowski » Wed Apr 07, 2021 8:37 pm

Hello,

We couldn't reproduce the issue. Please check the attached sample.

Thank you.
Attachments
Samples-Blazor-WebAssembly-main.zip
(382.21 KiB) Downloaded 5 times
mrapi
Posts: 252
Joined: Sat Dec 20, 2008 1:08 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by mrapi » Thu Apr 08, 2021 5:38 am

Hi
in your sample there is no report inside a modal as there is in #post1 sample, please recheck it
Lech Kulikowski
Posts: 3463
Joined: Tue Mar 20, 2018 5:34 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by Lech Kulikowski » Fri Apr 09, 2021 1:29 pm

Hello,

We need some additional time to investigate the issue, we will let you know about the result.

Thank you.
Lech Kulikowski
Posts: 3463
Joined: Tue Mar 20, 2018 5:34 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by Lech Kulikowski » Mon Apr 12, 2021 9:37 pm

Hello,

We still couldn't reproduce the issue. Please provide more detailed information on how to reproduce the issue.

Thank you.
mrapi
Posts: 252
Joined: Sat Dec 20, 2008 1:08 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by mrapi » Tue Apr 13, 2021 5:46 am

Hi,seems I put wrong sample on post#1,now I've updated,please redownload it
Lech Kulikowski
Posts: 3463
Joined: Tue Mar 20, 2018 5:34 am

Re: 'StiJsViewer' was undefined when display Blazor WebAssembly report in modal

Post by Lech Kulikowski » Tue Apr 13, 2021 6:41 am

Hello,

Thank you. We will check it and will let you know about the result.
Post Reply