How can I fix error CS0433 when I use stimulsoft report

Stimulsoft Reports.Net discussion
Post Reply
dorsa2
Posts: 8
Joined: Mon Apr 15, 2019 6:23 am

How can I fix error CS0433 when I use stimulsoft report

Post by dorsa2 » Mon Jun 24, 2019 8:09 am

I Use StimulSoft Report in my Asp.net project.

At first, I use the St Report in my web form 3 month ago. and it doesn't any problem. but now when I want to use StWebViewer in my form I faced to below error:

The "StiWebViewer was successfully added to the toolbox but are not enabled in the active designer"

after that I Install the Report Viewer control NuGet package via the NuGet package manager console:

Code: Select all

Install-Package Microsoft.ReportingServices.ReportViewerControl.WebForms
Now And when I want to Run my web form I faced to below error:
The type 'StiWebViewer' exists in both 'Stimulsoft.Report.Web, Version=2017.1.3.0, Culture=neutral, PublicKeyToken=ebe6666cba19647a' and 'Stimulsoft.Report.WebViewer, Version=2017.1.3.0, Culture=neutral, PublicKeyToken=ebe6666cba19647a'

And in my web.config file :

Code: Select all

  <handlers>
      <add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=15.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91"/>
    </handlers>
How Can I fix this problem?!
Lech Kulikowski
Posts: 1871
Joined: Tue Mar 20, 2018 5:34 am

Re: How can I fix error CS0433 when I use stimulsoft report

Post by Lech Kulikowski » Mon Jun 24, 2019 8:33 pm

Hello,

Please send us a sample project which reproduces the issue for analysis.

Thank you.
Post Reply