Issue Regarding HTML Tags

Stimulsoft Reports.NET discussion
Post Reply
rpm97
Posts: 2
Joined: Tue Jun 21, 2022 12:13 pm

Issue Regarding HTML Tags

Post by rpm97 »

Hi Team,

For some of the fields I have set "allowHtmlTags" to true. And the field value contains valid html tag and also < symbol. So html tag is working but text after < symbol is not showing in the report.
Example - Field value is like this -> <i>Value <i/> is < 5 .
So above line is showing only "Value is". but the expected result should be Value is < 5
So is there any way by which report only convert the valid html tag.

Please suggest any solution if there is any.

Thanks
Lech Kulikowski
Posts: 4576
Joined: Tue Mar 20, 2018 5:34 am

Re: Issue Regarding HTML Tags

Post by Lech Kulikowski »

Hello,

You can use the following expression:
<i>Value <i/> is &gt; 5 .

Thank you.
rpm97
Posts: 2
Joined: Tue Jun 21, 2022 12:13 pm

Re: Issue Regarding HTML Tags

Post by rpm97 »

Hi Lech,

Thanks for the quick response.
I am aware about the implementation that you have suggested. Is there any other way to implement this one or we have only one choice to convert the data in given form. I am asking for other ways because the data which we will show is dynamic and I am just trying to avoid data conversion. Please suggest if there is any alternative way by which only valid html tag gets converted and other text remains same.
Thanks in advance.
Lech Kulikowski
Posts: 4576
Joined: Tue Mar 20, 2018 5:34 am

Re: Issue Regarding HTML Tags

Post by Lech Kulikowski »

Hello,

Unfortunately, no.
Post Reply