Problems with date filters

Stimulsoft BI Designer discussion
Post Reply
Yannick
Posts: 3
Joined: Mon Jun 20, 2022 3:08 pm

Problems with date filters

Post by Yannick »

Hello

In a new report, when I create a new variable with no default value, like this :
NewVariable.gif
NewVariable.gif (25.66 KiB) Viewed 88 times
And I display the preview, then the date is initialized :
Preview.gif
Preview.gif (13.51 KiB) Viewed 88 times
How can I make it not initialized (empty date, with no date selected) when the report is displayed ?

I also have another problem : when I add a date filter with a value (no variable), like this :
DateFilter.gif
DateFilter.gif (24.91 KiB) Viewed 88 times
Then I see no result in the preview even if the filter should return data. How can I have data with this date filter ?


Report.mrt
(7.77 KiB) Downloaded 14 times

Thank you
Lech Kulikowski
Posts: 5129
Joined: Tue Mar 20, 2018 5:34 am

Re: Problems with date filters

Post by Lech Kulikowski »

Hello,

1. You can set the "Not Assigned" option for the nullable datetime type.

2. We need some additional time to investigate the issue, we will let you know about the result.

Thank you.
#9299
Lech Kulikowski
Posts: 5129
Joined: Tue Mar 20, 2018 5:34 am

Re: Problems with date filters

Post by Lech Kulikowski »

Hello,

The issue with types DateTime and DaetTimeOffset. Please try to use the following Expression in the Filter:
Summary_of_Sales_by_Quarters.ShippedDate > new DateTimeOffset(new DateTime(1994, 1, 1))

Thank you.
Post Reply