Dependency issues with reporter in .net core 3.0

Stimulsoft Reports.Web discussion
Post Reply
FrenkR
Posts: 116
Joined: Mon Jan 05, 2015 12:15 am

Dependency issues with reporter in .net core 3.0

Post by FrenkR » Wed Oct 09, 2019 9:10 pm

version Stimulsoft.Reports.Web.NetCore 2019.2.3 and 2019.3.7, .net core 3.0

when pacakage Stimulsoft.Reports.Web.NetCore and Microsoft.AspNetCore.Mvc.NewtonsoftJson are in the same (asp.net core), error "Detected package downgrade: System.Runtime.Extensions from 4.3.0 to 4.1.0. Reference the package directly from the project to select a different version.". Build is done successfully, publish "fails".

Steps to reproduce(Visual studio 2019 16.3.1 ):
1.)create new application from template "ASP.NET Core Web Application"
2.)add following references from nuget:
Microsoft.AspNetCore.Mvc.NewtonsoftJson version 3.0.0
Stimulsoft.Reports.Web.NetCore version 2019.3.7 or 2019.2.3

project dependencies should look as follows:
stimulsoft_ref2.png
stimulsoft_ref2.png (18.52 KiB) Viewed 52 times
3.) publish application to folder. When publishing, following errors occur:
stimulsoft_ref.png
stimulsoft_ref.png (64.09 KiB) Viewed 52 times
Test project/solution is attached.

Rgds,
Frenk
Attachments
reportLoadBug.zip
(8.02 KiB) Not downloaded yet
Lech Kulikowski
Posts: 1863
Joined: Tue Mar 20, 2018 5:34 am

Re: Dependency issues with reporter in .net core 3.0

Post by Lech Kulikowski » Thu Oct 10, 2019 10:27 am

Hello,

Unfortunately, at the current moment, we do not support .net core 3.0

We are working on that task now.

Thank you.
Post Reply