Variable get wrong values

Stimulsoft Reports.NET discussion
Post Reply
Frednews
Posts: 4
Joined: Tue Aug 02, 2022 4:16 pm

Variable get wrong values

Post by Frednews »

Hello

I have a data object like table.pricevalue with the value -30000.00
I want to use the value in a variable.

So I create the variable "additionalcosts" and I put in the expression table.pricevalue

I created to text fields in the report. One with the expression {table.pricevalue} wich shows -30000.0000 which is correct.
The other text field has the expression {additionalcosts}. It should display the same, but it shows 3000000.0000 and is not negative.

Normally the working with variables is running fine, but this is a strange behaviour.
Any ideas?

Thanks
Lech Kulikowski
Posts: 4760
Joined: Tue Mar 20, 2018 5:34 am

Re: Variable get wrong values

Post by Lech Kulikowski »

Hello,

Please send us a sample report with test data that reproduces the issue for analysis.

Thank you.
Frednews
Posts: 4
Joined: Tue Aug 02, 2022 4:16 pm

Re: Variable get wrong values

Post by Frednews »

Hi,

I attached a document with a little bit documentation of this behaviour.

Thanks
Attachments
variable_problem.pdf
(59.49 KiB) Downloaded 4 times
Lech Kulikowski
Posts: 4760
Joined: Tue Mar 20, 2018 5:34 am

Re: Variable get wrong values

Post by Lech Kulikowski »

Hello,

Please try to set the ReadOnly property for the variable.
If the issue is still present, please send us a sample report with test data that reproduces the issue for analysis.

Thank you.
Post Reply