Could not get filters working

Stimulsoft BI Designer discussion
Post Reply
d.pujdak
Posts: 12
Joined: Wed May 13, 2020 3:44 pm

Could not get filters working

Post by d.pujdak »

Hi everyone,

I am using a trial version of Report Designer (windows desktop).
I am trying to apply a filter from variable.

This is how I setup the OData data source:
screen_20240322_1125_340.png
screen_20240322_1125_340.png (18.29 KiB) Viewed 1148 times
screen_20240322_1126_342.png
screen_20240322_1126_342.png (9.24 KiB) Viewed 1148 times
I also tried this:
screen_20240322_1127_345.png
screen_20240322_1127_345.png (31.93 KiB) Viewed 1148 times
But nothing works as expected, is there something wrong I am doing?

I was following these docs: https://www.stimulsoft.com/en/documenta ... iables.htm
Lech Kulikowski
Posts: 6247
Joined: Tue Mar 20, 2018 5:34 am

Re: Could not get filters working

Post by Lech Kulikowski »

Hello,

What product and version are you use?

Also, if "Field Is"=Value, it is not possible to use a variable. In this case, you should use Expression.

Thank you.
d.pujdak
Posts: 12
Joined: Wed May 13, 2020 3:44 pm

Re: Could not get filters working

Post by d.pujdak »

Stimulsoft Designer Desktop,
Version: 2024.2.2 from 11 March 2024, WinForms, .Net 4.7.2
Trial Version
Lech Kulikowski
Posts: 6247
Joined: Tue Mar 20, 2018 5:34 am

Re: Could not get filters working

Post by Lech Kulikowski »

Hello,

Please send us a sample report with test data for analysis.

Also, if "Field Is"=Value, it is not possible to use a variable. In this case, you should use Expression.

Thank you.
d.pujdak
Posts: 12
Joined: Wed May 13, 2020 3:44 pm

Re: Could not get filters working

Post by d.pujdak »

Please find the sample report attached: https://file.io/RehwwoxBPAxt.
I was using OData feed: https://services.odata.org/TripPinRESTierService/ (see for more details: https://www.odata.org/odata-services/)

Thanks for looking at that.

Image
Lech Kulikowski
Posts: 6247
Joined: Tue Mar 20, 2018 5:34 am

Re: Could not get filters working

Post by Lech Kulikowski »

Hello,

As I said several times in previous replies you should use the Expression.

Thank you.
Attachments
Screenshot 2024-04-09 230243.png
Screenshot 2024-04-09 230243.png (41.19 KiB) Viewed 898 times
Post Reply